Categorías
Técnico

Instalar PHP 5.2x en CentOS Linux 5

Si por alguna razón necesitais instalar una versión más actual de PHP en vuestro servidor CentOS Enterprise Linux 5 aquí os explico donde podeis encontrar los paquetes rpm de php 5.2.x

El repositorio en cuestión es el de Utter Ramblings y en él se pueden encontrar versiones actuales de Apache, Mysql, PHP (con extensiones individuales), subversion,…

La dirección donde se encuentran los RPM’s es: http://www.jasonlitka.com/media/EL5/

Si os interesa añadir el repositorio a YUM

[utterramblings]
name=Jason's Utter Ramblings Repo
baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

Y la key GPG
rpm --import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

Fuente: Utter Ramblings

6 respuestas a «Instalar PHP 5.2x en CentOS Linux 5»

estimado la configuracion no me es efectiva en el centos 5.2 talvez podrias revisar la explicacion un poco mejor ya que la misma rpm no me es aceptada con el «yum»
mi caso es un
CENTOS 5.2 AL CUAL DESEO INSTALAR UN PHP 5.2.6
GRACIAS Y HASTA PRONTO

Hola Isaac,

No lo he probado con una CentOS 5.2, yo tengo la versión 5 en mis servidores, pero se me ocurre que puede ser un problema del baseurl, puedes probar a utilizar esta otra:

http://www.jasonlitka.com/media/EL5/i386/

o incluso puedes bajar los paquetes de php que necesites e instalarlos a mano desde la anterior dirección.

NOTA: en la url anterior he puesto i386, esto es para máquinas de 32 bits, si la tuya es de 64bits, sustitúyelo por x86_64

Saludos.

Hola.
Acabo de actualizar php de la versión 5.1 a la 5.9. (Si, el servidor CentOS 5.4-64 no es mio y llevaba tanto tiempo sin actualizarse).
Añadí CentOS-Testing y actualicé.
Todo salió sin errores, pero despues de actualizar, miro la versión (php -v) y me dice:

PHP Warning: PHP Startup: fileinfo: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=0
PHP compiled with module API=20060613, debug=0, thread-safety=0
These options need to match
in Unknown on line 0
PHP 5.2.9 (cli) (built: Jul 8 2009 05:59:13)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

¿Cómo puedo solucionar esto?
Gracias.

Deja una respuesta

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Salir /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Salir /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Salir /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Salir /  Cambiar )

Conectando a %s