Categorías
Técnico

Instalar AWN en Gutsy Gibbon

¿Te gusta la barra dock que tiene el MAC OS Leopard de Apple?
¿Te gustaría tener una parecida en tu Ubuntu Gutsy Gibbon?

Pues aquí te enseño como instalar Avant-Window-Navigator fácilmente.
Tienes que añadir estos repositorios al final del archivo /etc/apt/sources.list

#AWN
deb http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator
deb-src http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator

A continuación instalamos la clave de firmado para estos repositorios con el siguiente comando:
wget http://download.tuxfamily.org/syzygy42/reacocard.asc | sudo apt-key add reacocard.asc

Actualizamos los paquetes:
sudo apt-get update

Y ya podemos proceder a la instalación de Avant-Window-Navigator:
sudo apt-get install awn-core-applets-bzr libawn-bzr avant-window-navigator-bzr

Una vez instalado, ya podemos ejecutarlo desde el menú Aplicaciones -> Accesorios -> Avant Window Navigator

Si queremos que se arranque al iniciar el sistema, debemos configurarla desde el menú Sistema->Preferencias->Sesiones

Configurar AWN al inicio

Para añadir lanzadores a AWN sólo tenemos que arrastrarlos desde el menú Aplicaciones encima de la barra.

Avant-Window-Navigator

Fuente: Entre tuxes y pepinos

11 respuestas a “Instalar AWN en Gutsy Gibbon”

Hola, al hacer el apt-get update obtengo

E: Tipo ‘http://download.tuxfamily.org/syzygy42’ desconocido en la línea 43 de lista de fuentes /etc/apt/sources.list

tengo instalado y configurado compiz fussion en mi ubuntu gutsy habra algun conflicto si instalo AWN

Si queremos que se arranque al iniciar el sistema, debemos configurarla desde el menú Sistema->Preferencias->Sesiones .. -> Add
-> Command: “avant-window-navigator”

Hola! Segui tu tutorial pero cuando le doy

sudo apt-get install awn-core-applets-bzr libawn-bzr avant-window-navigator-bzr

Me dice :
Los siguientes paquetes tienen dependencias incumplidas:
avant-window-navigator-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado
awn-core-applets-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado
libawn-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado
E: Paquetes rotos

Hola Pam

Has ejecutado: sudo apt-get update
antes de apt-get install … ?

Para solventar los paquetes rotos, prueba a ejecutar: sudo apt-get -f install
y después ejecuta de nuevo la instalación.

hola sabes que tengo el siguiente problema, primero al actualizar me tira los sgte:
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
avant-window-navigator-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado
awn-core-applets-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado
libawn-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado
E: Paquetes rotos

y luego al tratar de instalar el awn me dice lo sgte:
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
avant-window-navigator-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado
awn-core-applets-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado
libawn-bzr: Depende: libpango1.0-0 (>= 1.18.3) pero 1.18.2-0ubuntu1 va a ser instalado

y no lo puedo instalar
ayuda porfavor
gracias

Sabes, eso sucede cuando no tienes los repositorios configurados. Haz un: sudo gedit /etc/apt/sources.list y borra todos los # de los deb http

Hola tengo el siguiente problema al hacer

wget http://download.tuxfamily.org/syzygy42/reacocard.asc | sudo apt-key add reacocard.asc

agregue los repositorios al source.list me tira

–16:40:57– http://download.tuxfamily.org/syzygy42/reacocard.asc
=> `reacocard.asc’
Resolviendo download.tuxfamily.org… gpg: no se puede abrir `reacocard.asc’: No existe el fichero ó directorio
88.191.250.18
Conectando a download.tuxfamily.org|88.191.250.18|:80… conectado.
Petición HTTP enviada, esperando respuesta… 404 Not Found
16:40:58 ERROR 404: Not Found.

saludos

Hola, me temo que el repositorio ha sido eliminado tal como indica su página: http://download.tuxfamily.org/syzygy42/index.html

Lo que hay que hacer es utilizar los repositorios de Launchpad.

En el archivo sources.list hay que añadir estos repositorios:

deb http://ppa.launchpad.net/reacocard-awn/ubuntu gutsy main
deb-src http://ppa.launchpad.net/reacocard-awn/ubuntu gutsy main

y después ya se puede instalar avant-window-navigator con este comando:

sudo apt-get install avant-window-navigator-bzr awn-core-applets-bzr awn-manager-bzr

Ya no hace falta instalar las claves de firmado.